What’s Vulnerable › Vulnerabilities
CVE-2026-33328: Possible integer overflow on 32-bit systems when reading GIF images
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-20 · updated 2026-08-19
- Weakness: CWE-190
Description
libvips is a fast image processing library with low memory needs. On 32-bit systems in versions before and including 8.18.0, the `gifload` operation could incorrectly determine dimensions leading to an integer overflow. This has been patched in version 8.18.1.
Affected products
- libvips: before 8.18.1 — fixed in 8.18.1
How to fix
Upgrade to a fixed version: libvips 8.18.1. Check the vendor advisory for mitigations.
References
- https://github.com/libvips/libvips/commit/9b633e45abfcf1fc4c84847007c81805193c0969
- https://github.com/libvips/libvips/pull/4935
- https://github.com/libvips/libvips/security/advisories/GHSA-r98w-4fp7-m9c7
Get alerted when CVE-2026-33328 or the next vulnerability affects your stack