What’s Vulnerable › Vulnerabilities
CVE-2026-33331: oRPC: Stored XSS in OpenAPI Reference Plugin via unescaped JSON.stringify
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-03-24 · updated 2026-06-17
- Weakness: CWE-79
Description
oRPC is an tool that helps build APIs that are end-to-end type-safe and adhere to OpenAPI standards. Prior to version 1.13.9, a stored cross-site scripting (XSS) vulnerability exists in the OpenAPI documentation generation of orpc. If an attacker can control any field within the OpenAPI specification (such as info.description), they can break out of the JSON context and execute arbitrary JavaScript when a user views the generated API documentation. This issue has been patched in version 1.13.9.
Affected products
- middleapi orpc: before 1.13.9 — fixed in 1.13.9
How to fix
Upgrade to a fixed version: middleapi orpc 1.13.9. Check the vendor advisory for mitigations.
References
- https://github.com/middleapi/orpc/commit/4f0efa8a1d3fa8e8317a4b03cc3945a5dfd68add
- https://github.com/middleapi/orpc/releases/tag/v1.13.9
- https://github.com/middleapi/orpc/security/advisories/GHSA-7f6v-3gx7-27q8
- https://github.com/middleapi/orpc/security/advisories/GHSA-7f6v-3gx7-27q8
Get alerted when CVE-2026-33331 or the next vulnerability affects your stack