What’s Vulnerable › Vulnerabilities
CVE-2026-33337: Firebird has a buffer overflow when parsing corrupted slice packets
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-04-17 · updated 2026-10-26
- Weakness: CWE-120
Description
Firebird is an open-source relational database management system. In versions prior to 5.0.4, 4.0.7 and 3.0.14, when deserializing a slice packet, the xdr_datum() function does not validate that a cstring length conforms to the slice descriptor bounds, allowing a cstring longer than the allocated buffer to overflow it. An unauthenticated attacker can exploit this by sending a crafted packet to the server, potentially causing a crash or other security impact. This issue has been fixed in versions 5.0.4, 4.0.7 and 3.0.14.
Affected products
- FirebirdSQL firebird: from 3.0.0 before 3.0.14; from 4.0.0 before 4.0.7; from 5.0.0 before 5.0.4 — fixed in 3.0.14, 4.0.7, 5.0.4
How to fix
Upgrade to a fixed version: FirebirdSQL firebird 3.0.14, 4.0.7, 5.0.4. Check the vendor advisory for mitigations.
References
- https://github.com/FirebirdSQL/firebird/releases/tag/v3.0.14
- https://github.com/FirebirdSQL/firebird/releases/tag/v4.0.7
- https://github.com/FirebirdSQL/firebird/releases/tag/v5.0.4
- https://github.com/FirebirdSQL/firebird/security/advisories/GHSA-89mq-229g-x47p
Get alerted when CVE-2026-33337 or the next vulnerability affects your stack