What’s Vulnerable › Vulnerabilities
CVE-2026-33346: OpenEMR has stored XSS in portal_payment.php via Unescaped table_args
- Severity: high (CVSS 8.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-03-19 · updated 2026-06-17
- Weakness: CWE-79
Description
OpenEMR is a free and open source electronic health records and medical practice management application. Prior to 8.0.0.2, a stored cross-site scripting (XSS) vulnerability in the patient portal payment flow allows a patient portal user to persist arbitrary JavaScript that executes in the browser of a staff member who reviews the payment submission. The payload is stored via `portal/lib/paylib.php` and rendered without escaping in `portal/portal_payment.php`. Version 8.0.0.2 fixes the issue.
Affected products
- openemr: before 8.0.0.2 — fixed in 8.0.0.2
How to fix
Upgrade to a fixed version: openemr 8.0.0.2. Check the vendor advisory for mitigations.
References
- https://github.com/openemr/openemr/commit/6e9e1566d6e271a6d839614674b887e3a73d7da1
- https://github.com/openemr/openemr/security/advisories/GHSA-qvf6-6xc6-9qv7
- https://github.com/openemr/openemr/security/advisories/GHSA-qvf6-6xc6-9qv7
Get alerted when CVE-2026-33346 or the next vulnerability affects your stack