What’s Vulnerable › Vulnerabilities
CVE-2026-33348: OpenEMR has Stored XSS in patient encounter Eye Exam form $CHRONIC2 and $CHRONIC3
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-03-25 · updated 2026-06-17
- Weakness: CWE-79
Description
OpenEMR is a free and open source electronic health records and medical practice management application. Users with the `Notes - my encounters` role can fill Eye Exam forms in patient encounters. The answers to the form are displayed on the encounter page and in the visit history for the users with the same role. Versions prior to 8.0.0.3 have a stored cross-site scripting (XSS) vulnerability in the function to display the form answers, allowing any authenticated attacker with the specific role to insert arbitrary JavaScript into the system by entering malicious payloads to the form answers. The JavaScript code is later executed by any user with the form role when viewing the form answers in the patient encounter pages or visit history. Version 8.0.0.3 contains a patch.
Affected products
- openemr: before 8.0.0.3 — fixed in 8.0.0.3
How to fix
Upgrade to a fixed version: openemr 8.0.0.3. Check the vendor advisory for mitigations.
References
- https://github.com/openemr/openemr/commit/f488efbe3eb7f17d0f057f960020cb611149f8a2
- https://github.com/openemr/openemr/releases/tag/v8_0_0_3
- https://github.com/openemr/openemr/security/advisories/GHSA-6ch2-p26g-x33h
- https://github.com/openemr/openemr/security/advisories/GHSA-6ch2-p26g-x33h
Get alerted when CVE-2026-33348 or the next vulnerability affects your stack