What’s Vulnerable › Vulnerabilities
CVE-2026-33349: fast-xml-parser: Entity Expansion Limits Bypassed When Set to Zero Due to JavaScript Falsy Evaluation
- Severity: medium (CVSS 5.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-03-24 · updated 2026-06-17
- Weakness: CWE-1284
Description
fast-xml-parser allows users to process XML from JS object without C/C++ based libraries or callbacks. From version 4.0.0-beta.3 to before version 5.5.7, the DocTypeReader in fast-xml-parser uses JavaScript truthy checks to evaluate maxEntityCount and maxEntitySize configuration limits. When a developer explicitly sets either limit to 0 — intending to disallow all entities or restrict entity size to zero bytes — the falsy nature of 0 in JavaScript causes the guard conditions to short-circuit, completely bypassing the limits. An attacker who can supply XML input to such an application can trigger unbounded entity expansion, leading to memory exhaustion and denial of service. This issue has been patched in version 5.5.7.
Affected products
- NaturalIntelligence fast-xml-parser: from 4.0.1 before 4.5.5; from 5.0.0 before 5.5.7; 4.0.0, 4.0.0-beta3, 4.0.0-beta4, 4.0.0-beta5, 4.0.0-beta6, 4.0.0-beta7 (+1) — fixed in 4.5.5, 5.5.7
How to fix
Upgrade to a fixed version: NaturalIntelligence fast-xml-parser 4.5.5, 5.5.7. Check the vendor advisory for mitigations.
References
- https://github.com/NaturalIntelligence/fast-xml-parser/commit/239b64aa1fc5c5455ddebbbb54a187eb68c9fdb7
- https://github.com/NaturalIntelligence/fast-xml-parser/security/advisories/GHSA-jp2q-39xq-3w4g
- https://github.com/NaturalIntelligence/fast-xml-parser/security/advisories/GHSA-jp2q-39xq-3w4g
Get alerted when CVE-2026-33349 or the next vulnerability affects your stack