What’s Vulnerable › Vulnerabilities
CVE-2026-33386: XSS in QuickCMS
- Severity: low (CVSS 2.3 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-29 · updated 2026-07-21
- Weakness: CWE-79
Description
QuickCMS is vulnerable to Cross-Site Scripting (XSS) through its insecure HTTP-based plugin‑fetching mechanism. A malicious attacker can perform a Man‑in‑the‑Middle (MITM) attack by impersonating the opensolution.org server and serving arbitrary HTML or JavaScript at the plugin list endpoint. When a user accesses the plugin page, the malicious content is automatically fetched, rendered, and executed. This issue was fixed in a patch to version 6.8 published on 15.05.2026, deployments without this patch are still vulnerable.
Affected products
- OpenSolution QuickCMS: through 6.8
References
Get alerted when CVE-2026-33386 or the next vulnerability affects your stack