What’s Vulnerable › Vulnerabilities
CVE-2026-33394: Discourse leaks PM post edits to moderators
- Severity: low (CVSS 2.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-19 · updated 2026-06-17
- Weakness: CWE-200
Description
Discourse is an open-source discussion platform. Prior to versions 2026.3.0-latest.1, 2026.2.1, and 2026.1.2, the Post Edits admin report (/admin/reports/post_edits) leaked the first 40 characters of raw post content from private messages and secure categories to moderators who shouldn't have access. Versions 2026.3.0-latest.1, 2026.2.1, and 2026.1.2 contain a patch. No known workarounds are available.
Affected products
- discourse: from 2026.1.0 before 2026.1.2; from 2026.2.0 before 2026.2.1; 2026.3.0 — fixed in 2026.1.2, 2026.2.1
How to fix
Upgrade to a fixed version: discourse 2026.1.2, 2026.2.1. Check the vendor advisory for mitigations.
References
- https://github.com/discourse/discourse/commit/3bf3793a708662716c0a4eaf64ae091abe71ab4c
- https://github.com/discourse/discourse/commit/473288219e93cd17576cf15e4f0b9e388a31d0c1
- https://github.com/discourse/discourse/commit/62721429d4402505d21280bcbe5894032447d800
- https://github.com/discourse/discourse/security/advisories/GHSA-wxvr-pm5c-829p
Get alerted when CVE-2026-33394 or the next vulnerability affects your stack