What’s Vulnerable › Vulnerabilities

CVE-2026-33395: Discourse has stored click‑based XSS via Graphviz SVG javascript: links

Description

Discourse is an open-source discussion platform. Prior to versions 2026.3.0-latest.1, 2026.2.1, and 2026.1.2, the discourse-graphviz plugin contains a stored cross-site scripting (XSS) vulnerability that allows authenticated users to inject malicious JavaScript code through DOT graph definitions. For instances with CSP disabled only. Versions 2026.3.0-latest.1, 2026.2.1, and 2026.1.2 contain a patch. As a workaround, disable the graphviz plugin, upgrade to a patched version, or enable a content security policy.

Affected products

How to fix

Upgrade to a fixed version: discourse 2026.1.2, 2026.2.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-33395 or the next vulnerability affects your stack