What’s Vulnerable › Vulnerabilities
CVE-2026-33400: Wallos: Stored cross-site scripting (XSS) vulnerability in the payment method rename endpoint
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-03-24 · updated 2026-06-17
- Weakness: CWE-79
Description
Wallos is an open-source, self-hostable personal subscription tracker. Prior to version 4.7.0, a stored cross-site scripting (XSS) vulnerability in the payment method rename endpoint allows any authenticated user to inject arbitrary JavaScript that executes when any user visits the Settings, Subscriptions, or Statistics pages. Combined with the wallos_login authentication cookie lacking the HttpOnly flag, this enables full session hijacking. This issue has been patched in version 4.7.0.
Affected products
- ellite Wallos: before 4.7.0 — fixed in 4.7.0
How to fix
Upgrade to a fixed version: ellite Wallos 4.7.0. Check the vendor advisory for mitigations.
References
- https://github.com/ellite/Wallos/commit/e87387f0ebb540cd33e6dfda7181db9db650ecef
- https://github.com/ellite/Wallos/security/advisories/GHSA-p6v5-227f-f3fv
Get alerted when CVE-2026-33400 or the next vulnerability affects your stack