What’s Vulnerable › Vulnerabilities
CVE-2026-33409: Parse Server: Auth provider validation bypass on login via partial authData
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-24 · updated 2026-06-17
- Weakness: CWE-287
Description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to versions 8.6.52 and 9.6.0-alpha.41, an authentication bypass vulnerability allows an attacker to log in as any user who has linked a third-party authentication provider, without knowing the user's credentials. The attacker only needs to know the user's provider ID to gain full access to their account, including a valid session token. This affects Parse Server deployments where the server option allowExpiredAuthDataToken is set to true. The default value is false. This issue has been patched in versions 8.6.52 and 9.6.0-alpha.41.
Affected products
- parse-community parse-server: before 8.6.52; from 9.0.0 before 9.6.0; 9.6.0-alpha1, 9.6.0-alpha10, 9.6.0-alpha11, 9.6.0-alpha12, 9.6.0-alpha13, 9.6.0-alpha14 (+34) — fixed in 8.6.52, 9.6.0
How to fix
Upgrade to a fixed version: parse-community parse-server 8.6.52, 9.6.0. Check the vendor advisory for mitigations.
References
- https://github.com/parse-community/parse-server/commit/8d7df5639c4a35768fe8b78b4580b30e8a74721c
- https://github.com/parse-community/parse-server/commit/98f4ba5bcf2c199bfe6225f672e8edcd08ba732d
- https://github.com/parse-community/parse-server/pull/10246
- https://github.com/parse-community/parse-server/pull/10247
- https://github.com/parse-community/parse-server/security/advisories/GHSA-pfj7-wv7c-22pr
Get alerted when CVE-2026-33409 or the next vulnerability affects your stack