What’s Vulnerable › Vulnerabilities
CVE-2026-33411: Discourse's solved topic stream has potential stored XSS in topic title
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-20 · updated 2026-06-17
- Weakness: CWE-79
Description
Discourse is an open-source discussion platform. Versions prior to 2026.3.0-latest.1, 2026.2.1, and 2026.1.2 have a potential stored XSS in topic titles for the solved posts stream. Versions 2026.3.0-latest.1, 2026.2.1, and 2026.1.2 contain a patch. As a workaround, ensure that the Content Security Policy is enabled, and has not been modified in a way which would make it more vulnerable to XSS attacks.
Affected products
- discourse: from 2026.1.0 before 2026.1.2; from 2026.2.0 before 2026.2.1; 2026.3.0 — fixed in 2026.1.2, 2026.2.1
How to fix
Upgrade to a fixed version: discourse 2026.1.2, 2026.2.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-33411 or the next vulnerability affects your stack