What’s Vulnerable › Vulnerabilities
CVE-2026-33412: Vim affected by Command injection via newline in glob()
- Severity: high (CVSS 7.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-24 · updated 2026-07-15
- Weakness: CWE-78
Description
Vim is an open source, command line text editor. Prior to version 9.2.0202, a command injection vulnerability exists in Vim's glob() function on Unix-like systems. By including a newline character (\n) in a pattern passed to glob(), an attacker may be able to execute arbitrary shell commands. This vulnerability depends on the user's 'shell' setting. This issue has been patched in version 9.2.0202.
Affected products
- vim/vim: before 9.2.0202 — fixed in 9.2.0202
How to fix
Upgrade to a fixed version: vim/vim 9.2.0202. Check the vendor advisory for mitigations.
References
- https://github.com/vim/vim/commit/645ed6597d1ea896c712cd7ddbb6edee79577e9a
- https://github.com/vim/vim/releases/tag/v9.2.0202
- https://github.com/vim/vim/security/advisories/GHSA-w5jw-f54h-x46c
- http://www.openwall.com/lists/oss-security/2026/03/19/10
- https://access.redhat.com/errata/RHSA-2026:10065
- https://access.redhat.com/errata/RHSA-2026:10097
- https://access.redhat.com/errata/RHSA-2026:11768
- https://access.redhat.com/errata/RHSA-2026:12274
- https://access.redhat.com/errata/RHSA-2026:14773
- https://access.redhat.com/errata/RHSA-2026:15087
- https://access.redhat.com/errata/RHSA-2026:16008
- https://access.redhat.com/errata/RHSA-2026:16009
Get alerted when CVE-2026-33412 or the next vulnerability affects your stack