What’s Vulnerable › Vulnerabilities
CVE-2026-33414: PowerShell Command Injection in Podman HyperV Machine
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-14 · updated 2026-07-24
- Weakness: CWE-78
Description
Podman is a tool for managing OCI containers and pods. Versions 4.8.0 through 5.8.1 contain a command injection vulnerability in the HyperV machine backend in pkg/machine/hyperv/stubber.go, where the VM image path is inserted into a PowerShell double-quoted string without sanitization, allowing $() subexpression injection. Because PowerShell evaluates subexpressions inside double-quoted strings before executing the outer command, an attacker who can control the VM image path through a crafted machine name or image directory can execute arbitrary PowerShell commands with the privileges of the Podman process. On typical Windows installations this means SYSTEM-level code execution, and only Windows is affected as the code is exclusive to the HyperV backend. This issue has been patched in version 5.8.2.
Affected products
- podman: from 4.8.0 before 5.8.2 — fixed in 5.8.2
How to fix
Upgrade to a fixed version: podman 5.8.2. Check the vendor advisory for mitigations.
References
- https://github.com/containers/podman/commit/571c842bd357ee626019ea97d030fb772fc654ed
- https://github.com/containers/podman/security/advisories/GHSA-hc8w-h2mf-hp59
- https://access.redhat.com/errata/RHSA-2026:8211
- https://access.redhat.com/security/cve/CVE-2026-33414
- https://bugzilla.redhat.com/show_bug.cgi?id=2458522
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-33414.json
Get alerted when CVE-2026-33414 or the next vulnerability affects your stack