What’s Vulnerable › Vulnerabilities
CVE-2026-33415: Discourse: Improper Access Control in discourse-ai Allows Unauthorized Category Content Exposure
- Severity: low (CVSS 2.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-31 · updated 2026-07-24
- Weakness: CWE-284
Description
Discourse is an open-source discussion platform. From versions 2026.1.0-latest to before 2026.1.3, 2026.2.0-latest to before 2026.2.2, and 2026.3.0-latest to before 2026.3.0, an authenticated moderator-level user could retrieve post content, topic titles, and usernames from categories they were not authorized to view. Insufficient access controls on a sentiment analytics endpoint allowed category permission boundaries to be bypassed. This issue has been patched in versions 2026.1.3, 2026.2.2, and 2026.3.0.
Affected products
- discourse: from 2026.1.0 before 2026.1.3; from 2026.2.0 before 2026.2.2; 2026.3.0 — fixed in 2026.1.3, 2026.2.2
How to fix
Upgrade to a fixed version: discourse 2026.1.3, 2026.2.2. Check the vendor advisory for mitigations.
References
- https://github.com/discourse/discourse/commit/e1bb146a1fadc863a516fbc26c6277273a025308
- https://github.com/discourse/discourse/security/advisories/GHSA-vj5f-gg8m-93xg
Get alerted when CVE-2026-33415 or the next vulnerability affects your stack