What’s Vulnerable › Vulnerabilities
CVE-2026-33439: Pre-Authentication Remote Code Execution via `jato.clientSession` Deserialization in OpenAM
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 9.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-04-07 · updated 2026-07-24
- Weakness: CWE-502
Description
Open Access Management (OpenAM) is an access management solution. Prior to 16.0.6, OpenIdentityPlatform OpenAM is vulnerable to pre-authentication Remote Code Execution (RCE) via unsafe Java deserialization of the jato.clientSession HTTP parameter. This bypasses the WhitelistObjectInputStream mitigation that was applied to the jato.pageSession parameter after CVE-2021-35464. An unauthenticated attacker can achieve arbitrary command execution on the server by sending a crafted serialized Java object as the jato.clientSession GET/POST parameter to any JATO ViewBean endpoint whose JSP contains <jato:form> tags (e.g., the Password Reset pages). This vulnerability is fixed in 16.0.6.
Affected products
- OpenIdentityPlatform OpenAM: before 16.0.6 — fixed in 16.0.6
How to fix
Upgrade to a fixed version: OpenIdentityPlatform OpenAM 16.0.6. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-33439 or the next vulnerability affects your stack