What’s Vulnerable › Vulnerabilities
CVE-2026-33498: Parse Server: Query condition depth bypass via pre-validation transform pipeline
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-24 · updated 2026-06-17
- Weakness: CWE-674
Description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to versions 8.6.55 and 9.6.0-alpha.44, an attacker can send an unauthenticated HTTP request with a deeply nested query containing logical operators to permanently hang the Parse Server process. The server becomes completely unresponsive and must be manually restarted. This is a bypass of the fix for CVE-2026-32944. This issue has been patched in versions 8.6.55 and 9.6.0-alpha.44.
Affected products
- parse-community parse-server: before 8.6.55; from 9.0.0 before 9.6.0; 9.6.0-alpha1, 9.6.0-alpha10, 9.6.0-alpha11, 9.6.0-alpha12, 9.6.0-alpha13, 9.6.0-alpha14 (+37) — fixed in 8.6.55, 9.6.0
How to fix
Upgrade to a fixed version: parse-community parse-server 8.6.55, 9.6.0. Check the vendor advisory for mitigations.
References
- https://github.com/parse-community/parse-server/commit/2581b5426047ce9cbcd3d9c0e8379e9c30e23ab5
- https://github.com/parse-community/parse-server/commit/85994eff9e7b34cac7e1a2f5791985022a1461d1
- https://github.com/parse-community/parse-server/pull/10257
- https://github.com/parse-community/parse-server/pull/10258
- https://github.com/parse-community/parse-server/security/advisories/GHSA-9fjp-q3c4-6w3j
Get alerted when CVE-2026-33498 or the next vulnerability affects your stack