What’s Vulnerable › Vulnerabilities
CVE-2026-33508: Parse Server: LiveQuery subscription query depth bypass
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-24 · updated 2026-06-17
- Weakness: CWE-674
Description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to versions 8.6.56 and 9.6.0-alpha.45, Parse Server's LiveQuery component does not enforce the requestComplexity.queryDepth configuration setting when processing WebSocket subscription requests. An attacker can send a subscription with deeply nested logical operators, causing excessive recursion and CPU consumption that degrades or disrupts service availability. This issue has been patched in versions 8.6.56 and 9.6.0-alpha.45.
Affected products
- parse-community parse-server: before 8.6.56; from 9.0.0 before 9.6.0; 9.6.0-alpha1, 9.6.0-alpha10, 9.6.0-alpha11, 9.6.0-alpha12, 9.6.0-alpha13, 9.6.0-alpha14 (+38) — fixed in 8.6.56, 9.6.0
How to fix
Upgrade to a fixed version: parse-community parse-server 8.6.56, 9.6.0. Check the vendor advisory for mitigations.
References
- https://github.com/parse-community/parse-server/commit/060d27053fb0fadf613c25aabab7fe0c82b7a899
- https://github.com/parse-community/parse-server/commit/2126fe4e12f9b399dc6b4b6a3fa70cb1825f159b
- https://github.com/parse-community/parse-server/pull/10259
- https://github.com/parse-community/parse-server/pull/10260
- https://github.com/parse-community/parse-server/security/advisories/GHSA-6qh5-m6g3-xhq6
Get alerted when CVE-2026-33508 or the next vulnerability affects your stack