What’s Vulnerable › Vulnerabilities
CVE-2026-33514: Discourse: Information Disclosure in Form Template API Due to Missing Authorization
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-19 · updated 2026-07-24
- Weakness: CWE-862
Description
Discourse is an open-source discussion platform. In versions prior to 2026.1.4, 2026.3.1, 2026.4.1 and 2026.5.0-latest.1, an authenticated user on a Discourse instance with the form templates feature enabled can read the name and structured content of form templates that are intended exclusively for categories they are not authorized to access. Impact is limited to disclosure of site configuration metadata. This issue has been fixed in versions 2026.1.4, 2026.3.1, 2026.4.1 and 2026.5.0-latest.1.
Affected products
- discourse: from 2026.1.0 before 2026.1.4; from 2026.3.0 before 2026.3.1; from 2026.4.0 before 2026.4.1; 2026.5.0 — fixed in 2026.1.4, 2026.3.1, 2026.4.1
How to fix
Upgrade to a fixed version: discourse 2026.1.4, 2026.3.1, 2026.4.1. Check the vendor advisory for mitigations.
References
- https://github.com/discourse/discourse/commit/ae5c9570fb918442c4d96abc83c1e7e169909b02
- https://github.com/discourse/discourse/security/advisories/GHSA-w6g7-p2p9-2m5h
Get alerted when CVE-2026-33514 or the next vulnerability affects your stack