What’s Vulnerable › Vulnerabilities
CVE-2026-33515: Squid has issues in ICP message handling
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-26 · updated 2026-06-17
- Weakness: CWE-125
Description
Squid is a caching proxy for the Web. Prior to version 7.5, due to improper input validation, Squid is vulnerable to out of bounds read when handling ICP traffic. This problem allows a remote attacker to receive small amounts of memory potentially containing sensitive information when responding with errors to invalid ICP requests. This attack is limited to Squid deployments that explicitly enable ICP support (i.e. configure non-zero `icp_port`). This problem cannot be mitigated by denying ICP queries using `icp_access` rules. Version 7.5 contains a patch.
Affected products
- Squid: before 7.5 — fixed in 7.5
How to fix
Upgrade to a fixed version: Squid 7.5. Check the vendor advisory for mitigations.
References
- https://github.com/squid-cache/squid/commit/8138e909d2058d4401e0ad49b583afaec912b165
- https://github.com/squid-cache/squid/pull/2220
- https://github.com/squid-cache/squid/pull/2220#discussion_r2727683637
- https://github.com/squid-cache/squid/security/advisories/GHSA-84p4-hcx7-jj7c
- http://www.openwall.com/lists/oss-security/2026/03/25/4
Get alerted when CVE-2026-33515 or the next vulnerability affects your stack