What’s Vulnerable › Vulnerabilities
CVE-2026-33516: xrdp: Pre-authentication out-of-bounds reads in RDP capability and channel parsers
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-17 · updated 2026-10-26
- Weakness: CWE-125
Description
xrdp is an open source RDP server. Versions through 0.10.5 contain an out-of-bounds read vulnerability during the RDP capability exchange phase. The issue occurs when memory is accessed before validating the remaining buffer length. A remote, unauthenticated attacker can trigger this vulnerability by sending a specially crafted Confirm Active PDU. Successful exploitation could lead to a denial of service (process crash) or potential disclosure of sensitive information from the process memory. This issue has been fixed in version 0.10.6.
Affected products
- neutrinolabs xrdp: before 0.10.6 — fixed in 0.10.6
How to fix
Upgrade to a fixed version: neutrinolabs xrdp 0.10.6. Check the vendor advisory for mitigations.
References
- https://github.com/neutrinolabs/xrdp/releases/tag/v0.10.6
- https://github.com/neutrinolabs/xrdp/security/advisories/GHSA-rvh9-9wm3-28c7
Get alerted when CVE-2026-33516 or the next vulnerability affects your stack