What’s Vulnerable › Vulnerabilities
CVE-2026-33520: BUG-000185167 - ArcGIS Server has a security vulnerability.
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-26 · updated 2026-10-26
- Weakness: CWE-79
Description
There is a reflected cross site scripting vulnerability in Esri Portal for ArcGIS versions 12.1 and prior which may allow a remote, unauthenticated attacker to create a crafted link which when clicked could potentially execute arbitrary JavaScript code in the victim’s browser. A patch is provided for impacted ArcGIS Server software in General Availability and Extended support status, which includes versions 11.5. Other versions are in mature or retired status, which are not patch eligible. Users working with unlisted versions are advised to upgrade and apply the patch.
Affected products
- Esri ArcGIS Server: from 11.1 before 12.1 — fixed in 12.1
How to fix
Upgrade to a fixed version: Esri ArcGIS Server 12.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-33520 or the next vulnerability affects your stack