What’s Vulnerable › Vulnerabilities
CVE-2026-33521: BUG-000186514 - ArcGIS Server has a security vulnerability.
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-26 · updated 2026-10-26
- Weakness: CWE-400
Description
There is s denial of service vulnerability in Esri ArcGIS Server versions 12.0 and prior that may allow a remote, unauthenticated attacker to supply crafted requests that may, under exceptional circumstances, consume all available worker threads and deny service to users. A patch is provided for ArcGIS Server software in General Availability and Extended support status, which includes versions 12.0, 11.5, 11.3, and 11.1. Other versions are in mature or retired status, which are not patch eligible. Users working with unlisted versions are advised to upgrade and apply the patch.
Affected products
- Esri ArcGIS Server: from 11.1 before 12.0 — fixed in 12.0
How to fix
Upgrade to a fixed version: Esri ArcGIS Server 12.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-33521 or the next vulnerability affects your stack