What’s Vulnerable › Vulnerabilities
CVE-2026-33523: Apache HTTP Server: multiple modules: HTTP response splitting forwarding malicious status line
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-04 · updated 2026-10-26
- Weakness: CWE-443
Description
HTTP response splitting vulnerability in multiple Apache HTTP Server modules with untrusted or compromised backend servers. This issue affects Apache HTTP Server: from through 2.4.66. Users are recommended to upgrade to version 2.4.67, which fixes the issue.
Affected products
- Apache HTTP Server: from 2.4.0 before 2.4.67 — fixed in 2.4.67
How to fix
Upgrade to a fixed version: Apache HTTP Server 2.4.67. Check the vendor advisory for mitigations.
References
- https://httpd.apache.org/security/vulnerabilities_24.html
- http://www.openwall.com/lists/oss-security/2026/05/04/23
Get alerted when CVE-2026-33523 or the next vulnerability affects your stack