What’s Vulnerable › Vulnerabilities
CVE-2026-33526: Squid vulnerable to Denial of Service in ICP Request handling
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 9.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-26 · updated 2026-07-15
- Weakness: CWE-416
Description
Squid is a caching proxy for the Web. Prior to version 7.5, due to heap Use-After-Free, Squid is vulnerable to Denial of Service when handling ICP traffic. This problem allows a remote attacker to perform a reliable and repeatable Denial of Service attack against the Squid service using ICP protocol. This attack is limited to Squid deployments that explicitly enable ICP support (i.e. configure non-zero `icp_port`). This problem _cannot_ be mitigated by denying ICP queries using `icp_access` rules. Version 7.5 contains a patch.
Affected products
- Squid: before 7.5 — fixed in 7.5
How to fix
Upgrade to a fixed version: Squid 7.5. Check the vendor advisory for mitigations.
References
- https://github.com/squid-cache/squid/commit/8a7d42f9d44befb8fcbbb619505587c8de6a1e91
- https://github.com/squid-cache/squid/security/advisories/GHSA-hpfx-h48q-gvwg
- http://www.openwall.com/lists/oss-security/2026/03/25/2
- https://access.redhat.com/errata/RHSA-2026:10255
- https://access.redhat.com/errata/RHSA-2026:10256
- https://access.redhat.com/errata/RHSA-2026:10257
- https://access.redhat.com/errata/RHSA-2026:11901
- https://access.redhat.com/errata/RHSA-2026:20564
- https://access.redhat.com/errata/RHSA-2026:20565
- https://access.redhat.com/errata/RHSA-2026:20580
- https://access.redhat.com/errata/RHSA-2026:6301
- https://access.redhat.com/errata/RHSA-2026:8119
Get alerted when CVE-2026-33526 or the next vulnerability affects your stack