What’s Vulnerable › Vulnerabilities
CVE-2026-33527: Parse Server: Session update endpoint allows overwriting server-generated session fields
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-24 · updated 2026-06-17
- Weakness: CWE-863
Description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to versions 8.6.57 and 9.6.0-alpha.48, an authenticated user can overwrite server-generated session fields such as expiresAt and createdWith when updating their own session via the REST API. This allows bypassing the server's configured session lifetime policy, making a session effectively permanent. This issue has been patched in versions 8.6.57 and 9.6.0-alpha.48.
Affected products
- parse-community parse-server: before 8.6.57; from 9.0.0 before 9.6.0; 9.6.0-alpha1, 9.6.0-alpha10, 9.6.0-alpha11, 9.6.0-alpha12, 9.6.0-alpha13, 9.6.0-alpha14 (+41) — fixed in 8.6.57, 9.6.0
How to fix
Upgrade to a fixed version: parse-community parse-server 8.6.57, 9.6.0. Check the vendor advisory for mitigations.
References
- https://github.com/parse-community/parse-server/commit/26b628c8fb3cc79ea955374769eebcff6f8a8a73
- https://github.com/parse-community/parse-server/commit/ea68fc0b22a6056c9675149469ff57817f7cf984
- https://github.com/parse-community/parse-server/pull/10263
- https://github.com/parse-community/parse-server/pull/10264
- https://github.com/parse-community/parse-server/security/advisories/GHSA-jc39-686j-wp6q
Get alerted when CVE-2026-33527 or the next vulnerability affects your stack