What’s Vulnerable › Vulnerabilities
CVE-2026-33534: EspoCRM has authenticated SSRF via internal-host validation bypass using alternative IPv4 notation
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-04-13 · updated 2026-06-17
- Weakness: CWE-918
Description
EspoCRM is an open source customer relationship management application. Versions 9.3.3 and below have an authenticated Server-Side Request Forgery (SSRF) vulnerability that allows bypassing the internal-host validation logic by using alternative IPv4 representations such as octal notation (e.g., 0177.0.0.1 instead of 127.0.0.1). This is caused by HostCheck::isNotInternalHost() function relying on PHP's filter_var(..., FILTER_VALIDATE_IP), which does not recognize alternative IP formats, causing the validation to fall through to a DNS lookup that returns no records and incorrectly treats the host as safe, however the cURL subsequently normalizes the address and connects to the loopback destination. Through the confirmed /api/v1/Attachment/fromImageUrl endpoint, an authenticated user can force the server to make requests to loopback-only services and store the fetched response as an attachment. This vulnerability is distinct from CVE-2023-46736 (which involved redirect-based SSRF) and may allow access to internal resources reachable from the application runtime. This issue has been fixed in version 9.3.4.
Affected products
- espocrm: before 9.3.4 — fixed in 9.3.4
How to fix
Upgrade to a fixed version: espocrm 9.3.4. Check the vendor advisory for mitigations.
References
- https://github.com/espocrm/espocrm/releases/tag/9.3.4
- https://github.com/espocrm/espocrm/security/advisories/GHSA-h7gx-8gwv-7g73
- https://github.com/espocrm/espocrm/security/advisories/GHSA-h7gx-8gwv-7g73
Get alerted when CVE-2026-33534 or the next vulnerability affects your stack