What’s Vulnerable › Vulnerabilities
CVE-2026-33538: Parse Server: Denial of service via unindexed database query for unconfigured auth providers
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-24 · updated 2026-06-17
- Weakness: CWE-400
Description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to versions 8.6.58 and 9.6.0-alpha.52, an unauthenticated attacker can cause denial of service by sending authentication requests with arbitrary, unconfigured provider names. The server executes a database query for each unconfigured provider before rejecting the request, and since no database index exists for unconfigured providers, each request triggers a full collection scan on the user database. This can be parallelized to saturate database resources. This issue has been patched in versions 8.6.58 and 9.6.0-alpha.52.
Affected products
- parse-community parse-server: before 8.6.58; from 9.0.0 before 9.6.0; 9.6.0-alpha1, 9.6.0-alpha10, 9.6.0-alpha11, 9.6.0-alpha12, 9.6.0-alpha13, 9.6.0-alpha14 (+45) — fixed in 8.6.58, 9.6.0
How to fix
Upgrade to a fixed version: parse-community parse-server 8.6.58, 9.6.0. Check the vendor advisory for mitigations.
References
- https://github.com/parse-community/parse-server/commit/40eb442e02672986730007d0a1edb22c1c4bd357
- https://github.com/parse-community/parse-server/commit/fbac847499e57f243315c5fc7135be1d58bb8e54
- https://github.com/parse-community/parse-server/pull/10270
- https://github.com/parse-community/parse-server/pull/10271
- https://github.com/parse-community/parse-server/security/advisories/GHSA-g4cf-xj29-wqqr
Get alerted when CVE-2026-33538 or the next vulnerability affects your stack