What’s Vulnerable › Vulnerabilities
CVE-2026-33539: Parse Server: SQL injection via aggregate and distinct field names in PostgreSQL adapter
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-24 · updated 2026-06-17
- Weakness: CWE-89
Description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to versions 8.6.59 and 9.6.0-alpha.53, an attacker with master key access can execute arbitrary SQL statements on the PostgreSQL database by injecting SQL metacharacters into field name parameters of the aggregate $group pipeline stage or the distinct operation. This allows privilege escalation from Parse Server application-level administrator to PostgreSQL database-level access. Only Parse Server deployments using PostgreSQL are affected. MongoDB deployments are not affected. This issue has been patched in versions 8.6.59 and 9.6.0-alpha.53.
Affected products
- parse-community parse-server: before 8.6.59; from 9.0.0 before 9.6.0; 9.6.0-alpha1, 9.6.0-alpha10, 9.6.0-alpha11, 9.6.0-alpha12, 9.6.0-alpha13, 9.6.0-alpha14 (+46) — fixed in 8.6.59, 9.6.0
How to fix
Upgrade to a fixed version: parse-community parse-server 8.6.59, 9.6.0. Check the vendor advisory for mitigations.
References
- https://github.com/parse-community/parse-server/commit/03249f9bf5b8783c8b848f84dab791ff0b761b8c
- https://github.com/parse-community/parse-server/commit/bdddab5f8b61a40cb8fc62dd895887bdd2f3838e
- https://github.com/parse-community/parse-server/pull/10272
- https://github.com/parse-community/parse-server/pull/10273
- https://github.com/parse-community/parse-server/security/advisories/GHSA-p2w6-rmh7-w8q3
Get alerted when CVE-2026-33539 or the next vulnerability affects your stack