What’s Vulnerable › Vulnerabilities

CVE-2026-33557: Apache Kafka: Missing JWT token validation in OAUTHBEARER authentication

Description

A possible security vulnerability has been identified in Apache Kafka. By default, the broker property `sasl.oauthbearer.jwt.validator.class` is set to `org.apache.kafka.common.security.oauthbearer.DefaultJwtValidator`. It accepts any JWT token without validating its signature, issuer, or audience. An attacker can generate a JWT token from any issuer with the `preferred_username` set to any user, and the broker will accept it. We advise the Kafka users using kafka v4.1.0 or v4.1.1 to set the config `sasl.oauthbearer.jwt.validator.class` to `org.apache.kafka.common.security.oauthbearer.BrokerJwtValidator` explicitly to avoid this vulnerability. Since Kafka v4.1.2 and v4.2.0 and later, the issue is fixed and will correctly validate the JWT token.

Affected products

How to fix

Upgrade to a fixed version: Apache Kafka 4.1.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-33557 or the next vulnerability affects your stack