What’s Vulnerable › Vulnerabilities
CVE-2026-33572: OpenClaw < 2026.2.17 - Insufficient File Permissions in Session Transcript Files
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-29 · updated 2026-06-17
- Weakness: CWE-378
Description
OpenClaw before 2026.2.17 creates session transcript JSONL files with overly broad default permissions, allowing local users to read transcript contents. Attackers with local access can read transcript files to extract sensitive information including secrets from tool output.
Affected products
- OpenClaw: before 2026.2.17 — fixed in 2026.2.17
How to fix
Upgrade to a fixed version: OpenClaw 2026.2.17. Check the vendor advisory for mitigations.
References
- https://github.com/openclaw/openclaw/commit/095d522099653367e1b76fa5bb09d4ddf7c8a57c
- https://github.com/openclaw/openclaw/security/advisories/GHSA-vr7j-g7jv-h5mp
- https://www.vulncheck.com/advisories/openclaw-insufficient-file-permissions-in-session-transcript-files
Get alerted when CVE-2026-33572 or the next vulnerability affects your stack