What’s Vulnerable › Vulnerabilities
CVE-2026-33577: OpenClaw < 2026.3.28 - Insufficient Scope Validation in node.pair.approve
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-31 · updated 2026-07-24
- Weakness: CWE-863
Description
OpenClaw before 2026.3.28 contains an insufficient scope validation vulnerability in the node pairing approval path that allows low-privilege operators to approve nodes with broader scopes. Attackers can exploit missing callerScopes validation in node-pairing.ts to extend privileges onto paired nodes beyond their authorization level.
Affected products
- OpenClaw: before 2026.3.28 — fixed in 2026.3.28
How to fix
Upgrade to a fixed version: OpenClaw 2026.3.28. Check the vendor advisory for mitigations.
References
- https://github.com/openclaw/openclaw/commit/4d7cc6bb4fac68b5a5fadd1c5a23168281221f34
- https://github.com/openclaw/openclaw/security/advisories/GHSA-2x4x-cc5g-qmmg
- https://www.vulncheck.com/advisories/openclaw-insufficient-scope-validation-in-node-pair-approve
Get alerted when CVE-2026-33577 or the next vulnerability affects your stack