What’s Vulnerable › Vulnerabilities
CVE-2026-33611: Insufficient validation of HTTPS and SVCB records
- Severity: medium (CVSS 4.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-22 · updated 2026-10-26
- Weakness: CWE-190
Description
An operator allowed to use the REST API can cause the Authoritative server to produce invalid HTTPS or SVCB record data, which can in turn cause LMDB database corruption, if using the LMDB backend.
Affected products
- PowerDNS Authoritative: from 4.9.0 before 4.9.14; from 5.0.0 before 5.0.4 — fixed in 4.9.14, 5.0.4
How to fix
Upgrade to a fixed version: PowerDNS Authoritative 4.9.14, 5.0.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-33611 or the next vulnerability affects your stack