What’s Vulnerable › Vulnerabilities
CVE-2026-33624: Parse Server: MFA recovery code single-use bypass via concurrent requests
- Severity: low (CVSS 2.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-24 · updated 2026-06-17
- Weakness: CWE-367
Description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to versions 8.6.60 and 9.6.0-alpha.54, an attacker who obtains a user's password and a single MFA recovery code can reuse that recovery code an unlimited number of times by sending concurrent login requests. This defeats the single-use design of recovery codes. The attack requires the user's password, a valid recovery code, and the ability to send concurrent requests within milliseconds. This issue has been patched in versions 8.6.60 and 9.6.0-alpha.54.
Affected products
- parse-community parse-server: before 8.6.60; from 9.0.0 before 9.6.0; 9.6.0-alpha1, 9.6.0-alpha10, 9.6.0-alpha11, 9.6.0-alpha12, 9.6.0-alpha13, 9.6.0-alpha14 (+47) — fixed in 8.6.60, 9.6.0
How to fix
Upgrade to a fixed version: parse-community parse-server 8.6.60, 9.6.0. Check the vendor advisory for mitigations.
References
- https://github.com/parse-community/parse-server/commit/5e70094250a36bfcc14ecd49592be2b94fba66ff
- https://github.com/parse-community/parse-server/commit/fc3da35a81d5083b453e8967cabcc880f1a3bd0c
- https://github.com/parse-community/parse-server/pull/10275
- https://github.com/parse-community/parse-server/pull/10276
- https://github.com/parse-community/parse-server/security/advisories/GHSA-2299-ghjr-6vjp
Get alerted when CVE-2026-33624 or the next vulnerability affects your stack