What’s Vulnerable › Vulnerabilities
CVE-2026-33626: LMDeploy Vulnerable to Server-Side Request Forgery (SSRF) via Vision-Language Image Loading
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 45.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-04-20 · updated 2026-10-26
- Weakness: CWE-918
Description
LMDeploy is a toolkit for compressing, deploying, and serving large language models. Versions prior to 0.12.3 have a Server-Side Request Forgery (SSRF) vulnerability in LMDeploy's vision-language module. The `load_image()` function in `lmdeploy/vl/utils.py` fetches arbitrary URLs without validating internal/private IP addresses, allowing attackers to access cloud metadata services, internal networks, and sensitive resources. Version 0.12.3 patches the issue.
Affected products
- InternLM lmdeploy: before 0.12.3 — fixed in 0.12.3
How to fix
Upgrade to a fixed version: InternLM lmdeploy 0.12.3. Check the vendor advisory for mitigations.
References
- https://github.com/InternLM/lmdeploy/commit/71d64a339edb901e9005358e0633fbbab367d626
- https://github.com/InternLM/lmdeploy/pull/4447
- https://github.com/InternLM/lmdeploy/releases/tag/v0.12.3
- https://github.com/InternLM/lmdeploy/security/advisories/GHSA-6w67-hwm5-92mq
- https://github.com/InternLM/lmdeploy/security/advisories/GHSA-6w67-hwm5-92mq
Get alerted when CVE-2026-33626 or the next vulnerability affects your stack