What’s Vulnerable › Vulnerabilities
CVE-2026-33627: Parse Server: Auth data exposed via /users/me endpoint
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-24 · updated 2026-06-17
- Weakness: CWE-200
Description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to versions 8.6.61 and 9.6.0-alpha.55, an authenticated user calling GET /users/me receives unsanitized auth data, including sensitive credentials such as MFA TOTP secrets and recovery codes. The endpoint internally uses master-level authentication for the session query, and the master context leaks through to the user data, bypassing auth adapter sanitization. An attacker who obtains a user's session token can extract MFA secrets to generate valid TOTP codes indefinitely. This issue has been patched in versions 8.6.61 and 9.6.0-alpha.55.
Affected products
- parse-community parse-server: before 8.6.61; from 9.0.0 before 9.6.0; 9.6.0-alpha1, 9.6.0-alpha10, 9.6.0-alpha11, 9.6.0-alpha12, 9.6.0-alpha13, 9.6.0-alpha14 (+48) — fixed in 8.6.61, 9.6.0
How to fix
Upgrade to a fixed version: parse-community parse-server 8.6.61, 9.6.0. Check the vendor advisory for mitigations.
References
- https://github.com/parse-community/parse-server/commit/5b8998e6866bcf75be7b5bb625e27d23bfaf912c
- https://github.com/parse-community/parse-server/commit/875cf10ac979bd60f70e7a0c534e2bc194d6982f
- https://github.com/parse-community/parse-server/pull/10278
- https://github.com/parse-community/parse-server/pull/10279
- https://github.com/parse-community/parse-server/security/advisories/GHSA-37mj-c2wf-cx96
Get alerted when CVE-2026-33627 or the next vulnerability affects your stack