What’s Vulnerable › Vulnerabilities
CVE-2026-33633: Kitty has a Heap Buffer Overflow in its Graphics Protocol Handler
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-05-19 · updated 2026-07-24
- Weakness: CWE-122
Description
Kitty is a cross-platform GPU based terminal. Versions 0.46.2 and below contain a heap buffer overflow in load_image_data() that allows any process which can write to the terminal's stdin to crash kitty immediately. The vulnerability is triggered by a single APC graphics protocol command with a PNG format declaration (f=100) whose payload exceeds twice the initial buffer capacity. The overflow is attacker-controlled in both length and content, causing DoS and potentially escalation to RCE itself. This issue has been fixed in version 0.47.0.
Affected products
- kovidgoyal kitty: before 0.47.0 — fixed in 0.47.0
How to fix
Upgrade to a fixed version: kovidgoyal kitty 0.47.0. Check the vendor advisory for mitigations.
References
- https://github.com/kovidgoyal/kitty/commit/e9661f0f3afb4e4dbffa509adfb3df3c9780ad34
- https://github.com/kovidgoyal/kitty/security/advisories/GHSA-j68c-v8x4-269g
- https://github.com/kovidgoyal/kitty/security/advisories/GHSA-j68c-v8x4-269g
Get alerted when CVE-2026-33633 or the next vulnerability affects your stack