What’s Vulnerable › Vulnerabilities
CVE-2026-33641: Glances Vulnerable to Command Injection via Dynamic Configuration Values
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-04-02 · updated 2026-10-26
- Weakness: CWE-78
Description
Glances is an open-source system cross-platform monitoring tool. Prior to version 4.5.3, Glances supports dynamic configuration values in which substrings enclosed in backticks are executed as system commands during configuration parsing. This behavior occurs in Config.get_value() and is implemented without validation or restriction of the executed commands. If an attacker can modify or influence configuration files, arbitrary commands will execute automatically with the privileges of the Glances process during startup or configuration reload. In deployments where Glances runs with elevated privileges (e.g., as a system service), this may lead to privilege escalation. This issue has been patched in version 4.5.3.
Affected products
- nicolargo glances: before 4.5.3 — fixed in 4.5.3
How to fix
Upgrade to a fixed version: nicolargo glances 4.5.3. Check the vendor advisory for mitigations.
References
- https://github.com/nicolargo/glances/commit/358d76a225fc21a9f95d2c4d7e46fafe64a644c6
- https://github.com/nicolargo/glances/releases/tag/v4.5.3
- https://github.com/nicolargo/glances/security/advisories/GHSA-qhj7-v7h7-q4c7
- https://github.com/nicolargo/glances/security/advisories/GHSA-qhj7-v7h7-q4c7
Get alerted when CVE-2026-33641 or the next vulnerability affects your stack