What’s Vulnerable › Vulnerabilities
CVE-2026-33642: Kitty has a Heap Buffer Over-Read/Write via Integer Overflow in compose_rectangles Bounds Check
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-05-19 · updated 2026-07-24
- Weakness: CWE-125
Description
Kitty is a cross-platform GPU based terminal. In versions 0.46.2 and below, the handle_compose_command() function in kitty/graphics.c performs bounds validation on composition offsets using unsigned 32-bit arithmetic that is subject to integer wrapping, potentially leading to Heap Buffer Over-Read/Write. An attacker who can write escape sequences to a kitty terminal (e.g., via a malicious file, SSH login banner, or piped content) can supply crafted x_offset/y_offset values that pass the bounds check after wrapping but cause massive out-of-bounds heap memory access in compose_rectangles(). No user interaction is required. No non-default configuration is required. The attacker only needs the ability to produce output in a kitty terminal window. This issue has been fixed in version 0.47.0.
Affected products
- kovidgoyal kitty: before 0.47.0 — fixed in 0.47.0
How to fix
Upgrade to a fixed version: kovidgoyal kitty 0.47.0. Check the vendor advisory for mitigations.
References
- https://github.com/kovidgoyal/kitty/commit/e9661f0f3afb4e4dbffa509adfb3df3c9780ad34
- https://github.com/kovidgoyal/kitty/security/advisories/GHSA-qfgm-2c64-6x3x
- https://github.com/kovidgoyal/kitty/security/advisories/GHSA-qfgm-2c64-6x3x
Get alerted when CVE-2026-33642 or the next vulnerability affects your stack