What’s Vulnerable › Vulnerabilities
CVE-2026-33658: Rails Active Storage has a possible DoS vulnerability in proxy mode via multi-range requests
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-26 · updated 2026-06-17
- Weakness: CWE-770
Description
Active Storage allows users to attach cloud and local files in Rails applications. Prior to versions 8.1.2.1, 8.0.4.1, and 7.2.3.1 Active Storage's proxy controller does not limit the number of byte ranges in an HTTP Range header. A request with thousands of small ranges causes disproportionate CPU usage compared to a normal request for the same file, possibly resulting in a DoS vulnerability. Versions 8.1.2.1, 8.0.4.1, and 7.2.3.1 contain a patch.
Affected products
- Ruby on Rails: before 7.2.3.1; from 8.0.0 before 8.0.4.1; from 8.1.0 before 8.1.2.1 — fixed in 7.2.3.1, 8.0.4.1, 8.1.2.1
- Rubygems Activestorage: from 8.1.0 before 8.1.2.1; from 8.0.0 before 8.0.4.1; before 7.2.3.1; 8.1.0, 8.1.1, 8.1.2, 8.0.0, 8.0.0.1, 8.0.1 (+165) — fixed in 8.1.2.1, 8.0.4.1, 7.2.3.1
How to fix
Upgrade to a fixed version: Ruby on Rails 7.2.3.1, 8.0.4.1, 8.1.2.1; Rubygems Activestorage 8.1.2.1, 8.0.4.1, 7.2.3.1. Check the vendor advisory for mitigations.
References
- https://github.com/rails/rails/releases/tag/v7.2.3.1
- https://github.com/rails/rails/releases/tag/v8.0.4.1
- https://github.com/rails/rails/releases/tag/v8.1.2.1
- https://github.com/rails/rails/security/advisories/GHSA-p9fm-f462-ggrg
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/activestorage/CVE-2026-33658.yml
Get alerted when CVE-2026-33658 or the next vulnerability affects your stack