What’s Vulnerable › Vulnerabilities
CVE-2026-33674: PrestaShop: Improper Use of Validation Framework
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-26 · updated 2026-06-17
- Weakness: CWE-1173
Description
PrestaShop is an open source e-commerce web application. Versions prior to 8.2.5 and 9.1.0 improperly use the validation framework. Versions 8.2.5 and 9.1.0 contain a fix. No known workarounds are available.
Affected products
- PrestaShop: before 8.2.5; from 9.0.0 before 9.1.0 — fixed in 8.2.5, 9.1.0
How to fix
Upgrade to a fixed version: PrestaShop 8.2.5, 9.1.0. Check the vendor advisory for mitigations.
References
- https://github.com/PrestaShop/PrestaShop/releases/tag/8.2.5
- https://github.com/PrestaShop/PrestaShop/releases/tag/9.1.0
- https://github.com/PrestaShop/PrestaShop/security/advisories/GHSA-283w-xf3q-788v
Get alerted when CVE-2026-33674 or the next vulnerability affects your stack