What’s Vulnerable › Vulnerabilities
CVE-2026-33756: Saleor Affected by Denial of Service via Unbounded GraphQL Query Batching
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-08 · updated 2026-07-24
- Weakness: CWE-770
Description
Saleor is an e-commerce platform. From 2.0.0 to before 3.23.0a3, 3.22.47, 3.21.54, and 3.20.118, Saleor supports query batching by submitting multiple GraphQL operations in a single HTTP request as a JSON array but wasn't enforcing any upper limit on the number of operations. This allowed an unauthenticated attacker to send a single HTTP request many operations (bypassing the per query complexity limit) to exhaust resources. This vulnerability is fixed in 3.23.0a3, 3.22.47, 3.21.54, and 3.20.118.
Affected products
- saleor: from 2.0.0 before 3.20.118; from 3.21.0 before 3.21.54; from 3.22.0 before 3.22.47; 3.23.0-alpha0, 3.23.0-alpha1, 3.23.0-alpha2 — fixed in 3.20.118, 3.21.54, 3.22.47
How to fix
Upgrade to a fixed version: saleor 3.20.118, 3.21.54, 3.22.47. Check the vendor advisory for mitigations.
References
- https://github.com/saleor/saleor/commit/7be352fa8c35875d6e66d36493ca7c14c101bd64
- https://github.com/saleor/saleor/commit/cdb66da97abb7c86939e384914cd8d9194f378e8
- https://github.com/saleor/saleor/commit/d6a94e95bd77f3f733fa66afd1b1ac72e863ca2a
- https://github.com/saleor/saleor/commit/e42aa4d6e588982e78942b033af051c8ec8f43fa
- https://github.com/saleor/saleor/commit/f0371bdd4cafcc841f1a9e7049cead6133bf7464
- https://github.com/saleor/saleor/security/advisories/GHSA-24jw-f244-qfpp
Get alerted when CVE-2026-33756 or the next vulnerability affects your stack