What’s Vulnerable › Vulnerabilities
CVE-2026-33758: OpenBao has Reflected XSS in its OIDC authentication error message
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-27 · updated 2026-07-15
- Weakness: CWE-20
Description
OpenBao is an open source identity-based secrets management system. Prior to version 2.5.2, OpenBao installations that have an OIDC/JWT authentication method enabled and a role with `callback_mode=direct` configured are vulnerable to XSS via the `error_description` parameter on the page for a failed authentication. This allows an attacker access to the token used in the Web UI by a victim. The `error_description` parameter has been replaced with a static error message in v2.5.2. The vulnerability can be mitigated by removing any roles with `callback_mode` set to `direct`.
Affected products
- openbao: before 2.5.2 — fixed in 2.5.2
How to fix
Upgrade to a fixed version: openbao 2.5.2. Check the vendor advisory for mitigations.
References
- https://github.com/openbao/openbao/commit/6e2b2dd84f0e47cebc90d6e79609dd5274732662
- https://github.com/openbao/openbao/pull/2709
- https://github.com/openbao/openbao/releases/tag/v2.5.2
- https://github.com/openbao/openbao/security/advisories/GHSA-cpj3-3r2f-xj59
- https://access.redhat.com/security/cve/CVE-2026-33758
- https://bugzilla.redhat.com/show_bug.cgi?id=2452294
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-33758.json
Get alerted when CVE-2026-33758 or the next vulnerability affects your stack