What’s Vulnerable › Vulnerabilities
CVE-2026-33793: Junos OS and Junos OS Evolved: When an unsigned Python op script configuration is present, a local low privileged user can compromise the system
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-09 · updated 2026-10-26
- Weakness: CWE-250
Description
An Execution with Unnecessary Privileges vulnerability in the User Interface (UI) of Juniper Networks Junos OS and Junos OS Evolved allows a local, low-privileged attacker to gain root privileges, thus compromising the system. When a configuration that allows unsigned Python op scripts is present on the device, a non-root user is able to execute malicious op scripts as a root-equivalent user, leading to privilege escalation. This issue affects Junos OS: * All versions before 22.4R3-S7, * from 23.2 before 23.2R2-S4, * from 23.4 before 23.4R2-S6, * from 24.2 before 24.2R1-S2, 24.2R2, * from 24.4 before 24.4R1-S2, 24.4R2; Junos OS Evolved: * All versions before 22.4R3-S7-EVO, * from 23.2 before 23.2R2-S4-EVO, * from 23.4 before 23.4R2-S6-EVO, * from 24.2 before 24.2R2-EVO, * from 24.4 before 24.4R1-S1-EVO, 24.4R2-EVO.
Affected products
- Juniper Junos OS: before 22.4; 22.4, 22.4-r1, 22.4-r1-s1, 22.4-r1-s2, 22.4-r2, 22.4-r2-s1 (+33) — fixed in 22.4
- Juniper Networks Junos OS Evolved: before 22.4; 22.4, 22.4-r1, 22.4-r1-s1, 22.4-r1-s2, 22.4-r2, 22.4-r2-s1 (+32) — fixed in 22.4
How to fix
Upgrade to a fixed version: Juniper Junos OS 22.4; Juniper Networks Junos OS Evolved 22.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-33793 or the next vulnerability affects your stack