What’s Vulnerable › Vulnerabilities
CVE-2026-33808: @fastify/express vulnerable to middleware authentication bypass via URL normalization gaps (duplicate slashes and semicolons)
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-04-15 · updated 2026-10-26
- Weakness: CWE-436
Description
Impact@fastify/express v4.0.4 and earlier fails to normalize URLs before passing them to Express middleware when Fastify router normalization options are enabled. This allows complete bypass of path-scoped authentication middleware via duplicate slashes when ignoreDuplicateSlashes is enabled, or via semicolon delimiters when useSemicolonDelimiter is enabled. In both cases, Fastify router normalizes the URL and matches the route, but @fastify/express passes the original un-normalized URL to Express middleware, which fails to match and is skipped. An unauthenticated attacker can access protected routes by manipulating the URL path. PatchesUpgrade to @fastify/express v4.0.5 or later.
Affected products
- Fastify/Express: before 4.0.5 — fixed in 4.0.5
How to fix
Upgrade to a fixed version: Fastify/Express 4.0.5. Check the vendor advisory for mitigations.
References
- https://cna.openjsf.org/security-advisories.html
- https://github.com/fastify/fastify-express/security/advisories/GHSA-6hw5-45gm-fj88
- https://github.com/fastify/fastify-express/security/advisories/GHSA-6hw5-45gm-fj88
Get alerted when CVE-2026-33808 or the next vulnerability affects your stack