What’s Vulnerable › Vulnerabilities
CVE-2026-33816: CVE-2026-33816 in github.com/jackc/pgx
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-07 · updated 2026-10-26
- Weakness: CWE-787
Description
Memory-safety vulnerability in github.com/jackc/pgx/v5.
Affected products
- jackc pgx: before 5.9.0 — fixed in 5.9.0
How to fix
Upgrade to a fixed version: jackc pgx 5.9.0. Check the vendor advisory for mitigations.
References
- https://pkg.go.dev/vuln/GO-2026-4772
- https://access.redhat.com/errata/RHSA-2026:11070
- https://access.redhat.com/errata/RHSA-2026:11217
- https://access.redhat.com/errata/RHSA-2026:13791
- https://access.redhat.com/errata/RHSA-2026:13829
- https://access.redhat.com/errata/RHSA-2026:13907
- https://access.redhat.com/errata/RHSA-2026:17789
- https://access.redhat.com/errata/RHSA-2026:19137
- https://access.redhat.com/errata/RHSA-2026:22423
- https://access.redhat.com/errata/RHSA-2026:24475
- https://access.redhat.com/errata/RHSA-2026:24479
- https://access.redhat.com/errata/RHSA-2026:24482
Get alerted when CVE-2026-33816 or the next vulnerability affects your stack