What’s Vulnerable › Vulnerabilities
CVE-2026-33858: Apache Airflow: Unsafe Deserialization via Legacy Serialization Keys (__type/__var) Bypass in XCom API
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-13 · updated 2026-10-26
- Weakness: CWE-502
Description
Dag Authors, who normally should not be able to execute code in the webserver context could craft XCom payload causing the webserver to execute arbitrary code. Since Dag Authors are already highly trusted, severity of this issue is Low. Users are recommended to upgrade to Apache Airflow 3.2.0, which resolves this issue.
Affected products
- Apache Airflow: from 3.1.8 before 3.2.0 — fixed in 3.2.0
How to fix
Upgrade to a fixed version: Apache Airflow 3.2.0. Check the vendor advisory for mitigations.
References
- https://github.com/apache/airflow/pull/64148
- https://lists.apache.org/thread/1npt3o2x81s0gw9tmfcv4n7p1z9hdmy0
- http://www.openwall.com/lists/oss-security/2026/04/13/7
Get alerted when CVE-2026-33858 or the next vulnerability affects your stack