What’s Vulnerable › Vulnerabilities
CVE-2026-33869: Mastodon has a denial of service for quote authorization
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-27 · updated 2026-06-17
- Weakness: CWE-863
Description
Mastodon is a free, open-source social network server based on ActivityPub. In versions on the 4.5.x branch prior to 4.5.8 and on the 4.4.x branch prior to 4.4.15, an attacker that knows of a quote before it has reached a server can prevent it from being correctly processed on that server. The vulnerability has been patched in Mastodon 4.5.8 and 4.4.15. Mastodon 4.3 and earlier are not affected because they do not support quotes.
Affected products
- mastodon: from 4.4.0 before 4.4.15; from 4.5.0 before 4.5.8 — fixed in 4.4.15, 4.5.8
How to fix
Upgrade to a fixed version: mastodon 4.4.15, 4.5.8. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-33869 or the next vulnerability affects your stack