What’s Vulnerable › Vulnerabilities
CVE-2026-33870: Netty: HTTP Request Smuggling via Chunked Extension Quoted-String Parsing
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-03-27 · updated 2026-09-14
- Weakness: CWE-444
Description
Netty is an asynchronous, event-driven network application framework. In versions prior to 4.1.132.Final and 4.2.10.Final, Netty incorrectly parses quoted strings in HTTP/1.1 chunked transfer encoding extension values, enabling request smuggling attacks. Versions 4.1.132.Final and 4.2.10.Final fix the issue.
Affected products
- netty: before 4.1.132; from 4.2.0 before 4.2.10 — fixed in 4.1.132, 4.2.10
How to fix
Upgrade to a fixed version: netty 4.1.132, 4.2.10. Check the vendor advisory for mitigations.
References
- https://github.com/netty/netty/security/advisories/GHSA-pwqr-wmgm-9rr8
- https://w4ke.info/2025/06/18/funky-chunks.html
- https://w4ke.info/2025/10/29/funky-chunks-2.html
- https://www.rfc-editor.org/rfc/rfc9110
- https://access.redhat.com/errata/RHSA-2026:10175
- https://access.redhat.com/errata/RHSA-2026:10184
- https://access.redhat.com/errata/RHSA-2026:13571
- https://access.redhat.com/errata/RHSA-2026:14272
- https://access.redhat.com/errata/RHSA-2026:14276
- https://access.redhat.com/errata/RHSA-2026:17668
- https://access.redhat.com/errata/RHSA-2026:17789
- https://access.redhat.com/errata/RHSA-2026:18054
Get alerted when CVE-2026-33870 or the next vulnerability affects your stack