What’s Vulnerable › Vulnerabilities
CVE-2026-33888: ApostropheCMS: publicApiProjection Bypass via `project` Query Builder in Piece-Type REST API
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-04-15 · updated 2026-10-26
- Weakness: CWE-200
Description
ApostropheCMS is an open-source Node.js content management system. Versions 4.28.0 and prior contain an authorization bypass vulnerability in the getRestQuery method of the @apostrophecms/piece-type module, where the method checks whether a MongoDB projection has already been set before applying the admin-configured publicApiProjection. An unauthenticated attacker can supply a project query parameter in the REST API request, which is processed by applyBuildersSafely before the permission check, pre-populating the projection state and causing the publicApiProjection to be skipped entirely. This allows disclosure of any field on publicly queryable documents that the administrator explicitly restricted from the public API, such as internal notes, draft content, or metadata. Exploitation is trivial, requiring only appending query parameters to a public URL with no authentication. This issue has been fixed in version 4.29.0.
Affected products
- apostrophecms apostrophe: before 4.29.0 — fixed in 4.29.0
How to fix
Upgrade to a fixed version: apostrophecms apostrophe 4.29.0. Check the vendor advisory for mitigations.
References
- https://github.com/apostrophecms/apostrophe/commit/00d472804bb622df36a761b6f2cf2b33b2d4ce80
- https://github.com/apostrophecms/apostrophe/commit/6c2b548dec2e3f7a82e8e16736603f4cd17525aa
- https://github.com/apostrophecms/apostrophe/security/advisories/GHSA-xhq9-58fw-859p
Get alerted when CVE-2026-33888 or the next vulnerability affects your stack